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iPhoto Step-by-Step

iPhoto makes it easy to organize, edit, and share digital photos. And iPhoto 
is a great tool to enhance lesson plans with digital photography. That’s why 
we’ve created this guide—to walk you through the finer points of creating 
specific parts of the ocean field trip project. 

This step-by-step guide should be used with the videos on the DVD. For the 
basics of how to use iPhoto to import photos, work with events, and organize 
photos, please watch the appropriate sections of the DVD.
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Create an Album
To create and arrange an Album:

In iPhoto, select all of the photos you want to use in your new album (in this case, all of 1	
the pictures from our field trip), then click the + button in the lower-left corner of the 
window. 

An album creation pane slides down.

   

When you create a new album, 
you’ll be asked to name it. 
Replace the “untitled album” 
text in the Name field with 
whatever text you like. In this 
case, we named the album 
“Field Trip.”

In the Name field, type the name of the project and then click Create. 2	

Your new album appears under the Albums heading.

   
The new album appears in the 
left column of iPhoto’s window. 

Create an Album
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Deselect the images by clicking anywhere outside them, but still inside the main photo 3	
window.

   
To deselect images, simply click 
in an area outside of a picture.

Rearrange the photos in the order you want by dragging them to a new position.4	

    

When you move images, 
a vertical line appears to 
indicate where the images will 
be moved when you release 
the mouse button.

Create an Album
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Delete any unwanted photos by first selecting the photo and then pressing Delete. 5	

Don’t worry—this only removes the picture from the album; the original is still safe in your 
library.

   

To remove images from an 
album, select them in the 
iPhoto window and press 
Delete.

   

The three images are removed 
from the album. They remain in 
the iPhoto library, however.

Create an Album
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Crop and Enhance a Photo
To crop a photo and enhance it:

In iPhoto, locate the image you want to crop and enhance.1	

   

We’ve chosen an image of a 
starfish that could use a little 
work.

In the lower-left corner of the window, click the Edit button. 2	

The selected image is brought into iPhoto’s editing mode. Other images in the same 
library are set horizontally across the top, and editing tools are arranged at the bottom.

   

iPhoto’s editing window, where 
you make changes to an image 
by using the tools along the 
bottom. You can also switch to 
a different image by clicking it 
in the strip along the window’s 
top.

Crop and Enhance a Photo
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In the lower-left portion of the iPhoto window, click the Crop tool. 3	

iPhoto creates a cropping rectangle around the image, and it displays a small options 
palette at the bottom of the rectangle that contains preset crop sizes, a constrain 
checkbox, and buttons to apply the crop or to cancel it.

   

iPhoto’s cropping rectangle 
lets you set your own cropping 
size, or you can choose a preset 
size from the popup menu in 
the crop control palette at the 
bottom.

Drag the edges of the rectangle so that it surrounds just the area of the photo that you 4	
want to keep.

   
Simply drag the sides of the 
rectangle to resize it.

Crop and Enhance a Photo
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Click Apply. iPhoto crops the image. If you don’t like how the crop turned out, press 5	
Command-Z to undo it and try again.

   
After clicking Apply, the image 
is cropped.

Click the Enhance button in iPhoto’s editing tools (at the bottom of the window). 6	

iPhoto automatically adjusts the image to improve color and levels.

   

Click Enhance to have iPhoto 
improve an image’s colors and 
levels.

Crop and Enhance a Photo
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When you’re satisfied with how your image looks, click Done. 7	

iPhoto returns to its browser mode.

   

If you want to undo any 
changes that you’ve made after 
you return to iPhoto’s image 
browser, select the edited 
image, and choose Photos -> 
Revert to Original.

Crop and Enhance a Photo
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Straighten and Adjust a Photo
To straighten a photo and make tonal and sharpness adjustments to it:

In iPhoto, select an image to straighten and adjust, then click the Edit button. 1	

The image is brought into iPhoto’s editing mode.

   

When you select an image and 
click Edit, iPhoto moves the 
image into editing mode.

In the lower-left portion of iPhoto’s window, click the Straighten button. 2	

A grid covers the image, and a rotation control appears at the bottom of the image.

   

iPhoto lets you rotate the 
image ten degrees right or left 
in very small increments.

Straighten and Adjust a Photo
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Drag the rotation control slider to rotate the image until you’re satisfied with the new 3	
position.

   
Here, we’ve rotated the image 
7.3 degrees counterclockwise.

Click the Adjust button at the bottom of the window. The Adjust inspector appears.4	

   

The sand is very light, and the 
anemone’s tendrils are dark 
around the opening, so we’ll 
use iPhoto’s Adjust inspector 
to fix this.

Straighten and Adjust a Photo
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Use the sliders in the inspector to make changes to the image. Click Done to accept the 5	
changes and return to iPhoto’s image browser.

   

We’ve toned down the sand 
and brought some detail in 
the anemone’s opening by 
reducing Levels to even out 
the image, and by reducing the 
highlight brightness.

   

Straighten and Adjust a Photo



iPhoto Step-by-Step

12	 For personal use only. Not for resale.

Creating a Slideshow
To create a slideshow:

In iPhoto, hold down the Shift key and select the images you want to use in a slideshow.1	

   

The first step in building a 
slideshow in iPhoto is to select 
the pictures you want to use, 
and create a new album for 
them. Here, we’ve selected 
several pictures from our field 
trip.

Choose File -> New Album From Selection.2	

   

The first step in building a 
slideshow in iPhoto is to select 
the pictures you want to use 
and create a new album for 
them.

Creating a Slideshow
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In the pane that slides down, click the Slideshow icon, and type in the name for your 3	
slideshow in the Name field. Once done, click Create.

   

When creating a slideshow, 
click the Slideshow icon in this 
dialog box and provide a name.

 A new Slideshows listing appears in iPhoto’s left sidebar.4	

   

All the pictures in the 
slideshow are displayed in 
a strip across the top of the 
window. The tools and settings 
are arranged along the bottom.

Creating a Slideshow
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Rearrange the photos in your slideshow by dragging them in the strip at the top of the 5	
window. To add photos, drag them onto the new slideshow. To remove photos, select 
them in the strip and press Delete.

   

You can rearrange the photos 
in your slideshow by selecting 
them and dragging them to a 
new location.

Select any effects and transitions you want from the Effects and Transition menus at the 6	
bottom of the window.

   

To change the transition 
between slides, select a new 
one from the Transition popup 
menu.

Creating a Slideshow
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Click Adjust to make changes to how the current picture in your slideshow behaves.7	

   

The “Adjust This Slide” inspector 
lets you change how long the 
current slide lasts and what 
transition is used with it.

Click Settings. A pane slides down, allowing you to change the slideshow’s settings. Once 8	
finished, click OK.

   

In the Settings pane, you can 
specify how long each slide 
lasts, which transition is used, 
how music interacts with the 
slideshow, and other settings.

Creating a Slideshow
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Click Music. 9	

A pane slides down, allowing you to add a soundtrack to the slideshow. Choose the music 
you’d like to include, and click OK. 

   

The Music pane allows you 
to select  from some music 
samples, your GarageBand 
library, or your iTunes library.

Your slideshow is ready to go. Click Play to run it full screen (or preview it by clicking the 10	
Preview button).

   

If you move the mouse while 
the slideshow plays, a set of 
controls is overlaid at the 
bottom of the image.

Creating a Slideshow
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Creating a Web Gallery
To create a .Mac web gallery:

In iPhoto, select the photos you want to post, and click Web Gallery in the bottom of the 1	
window.

   

Select the images you want to 
use, then click the Web Gallery 
button.

A pane slides down, asking you if you want to publish the photos to your Web Gallery. It 2	
also offers options on who can see it and what can be done with it.

   

The Web Gallery pane lets you 
set some permissions options 
for your visitors.

Creating a Web Gallery
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Choose who should see the album from the “Album Viewable By” menu. 3	

Your options include Everyone, Only me, or a group that you’ve created with a password 
(using “Edit Names and Password,” from the same popup menu). 

   

The “Album Viewable By” 
popup menu lets you specify 
who can see the Web Gallery. 
Here, we’re allowing anyone to 
see the gallery.

Check the options you want for your gallery in the Options checkboxes. 4	

You can show titles, allow users to download and upload photos, and even upload photos 
by email by checking the corresponding check boxes. 

   

The Options checkboxes let 
you specify the Web Gallery’s 
level of interactivity.

Creating a Web Gallery
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Click Publish to publish your photos to your .Mac Web Gallery. 5	

A Web Gallery listing appears in iPhoto’s left sidebar, and iPhoto begins uploading images 
to the gallery.

   

When you publish a Web 
Gallery, iPhoto will upload the 
images in the background. 
A progress bar appears in 
the upper-right corner of the 
window, showing how long it 
takes.

Creating a Web Gallery
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Creating a Book
To create and order a book:

In iPhoto, select the photos you want to use in your book, then click Book in the lower 1	
portion of the iPhoto window.

   

To create a book, select the 
images you want to use, then 
click the Book icon. 

Choose the kind of book you want to create in the book theme pane that slides down,  2	
and then click Choose.

   

The first thing you’ll be asked is 
to choose a theme and type for 
your book.

Creating a Book
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Your photos are loaded into the book template and a new book element is created in 3	
iPhoto’s left sidebar. Since the placeholder text is ready to be customized, type your book’s 
name and press Return.

   

Name your book in iPhoto’s left 
sidebar by typing its name and 
pressing Return.

Double-click the text on each page to make it editable, and type in the text you want to 4	
appear.

   

Type your own text by 
replacing the placeholder text. 
Here, we’re naming the book 
for the field trip.

Creating a Book
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Drag images onto the placeholder rectangles on your page from the strip at the top of the 5	
window to create your layout.

   

To add images to your book, 
drag them from the strip at the 
top of the window and onto 
the placeholders.

Click the left and right arrows in the lower-right part of the window to move through the 6	
pages of your book. On each page, edit the text and add photos as you like. 

You can easily swap photos around on a page by dragging them from one square to 
another, even after you’ve placed them.

   

Continue to build your book, 
page by page. Click the right 
arrow to move toward the back 
of the book; click the left arrow 
to move toward the front.

Creating a Book



iPhoto Step-by-Step

For personal use only. Not for resale.	 23

Use the Themes, Background, and Layout popup menus at the bottom to choose different 7	
book themes, background colors or images, or even change the layout of a given page.

   

To select a new background 
for a page, select it from the 
Background popup menu. 
Each iPhoto book theme 
has a different set of page 
backgrounds.

Click an image that you’ve placed on a page, and a zoom-and-pan control appears. Use 8	
this control to zoom into your image and move it around inside the rectangle until just 
the portion of the image you want is showing.

   

You can zoom in to a 
photo—effectively cropping 
it—by first selecting the photo 
and then sliding the zoom 
slider.

Creating a Book
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Click the Settings button. A font settings pane slides down, where you can customize the 9	
fonts and font sizes, as well as other book options. Make any desired changes here and 
click OK.

   

The Settings pane lets you 
control the fonts, photo 
information, and other options, 
such as page numbering.

Click “Buy Book.” Using your Apple account with 1-Click ordering, iPhoto walks you 10	
through the ordering process and then uploads your book to a professional printing 
company. 

   

Apple’s 1-Click order page lets 
you choose the color of the 
cover as well as how many you 
want to order, and it will tell 
you how approximately how 
much the book will cost.

Creating a Book
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Adding Metadata to Pictures
To add metadata to your iPhoto images:

In the lower-right corner of the iPhoto window, click the “i” button. The Information area 1	
slides up.

   

The Information area shows 
you the selected picture’s title, 
the date and time it was taken, 
the rating (if any), keywords, 
the image kind, its size, and its 
description.

Click the fields in the information area to change a picture’s title, rating, description, time, 2	
or date, and type the new item. 

   

Here, we’re changing the 
picture’s description—but 
the title, date, time, and rating 
metadata are all changeable 
as well.

Adding Metadata to Pictures
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Choose Window -> Keywords to show the Keywords inspector and add keywords to a 3	
picture. Select an image and then click one or more preset keywords in the Keywords 
palette. 

The keywords are added to the image.

   
Click a predefined keyword to 
add it to the selected image. 

Repeat these steps to refine your searches and to create Smart Albums.4	

Adding Metadata to Pictures
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Creating a Smart Album
To create a Smart Album:

In iPhoto, choose File -> New Smart Album. 1	

A Smart Album pane slides down.

   

The first step in creating a 
Smart Album is to give it a 
name and set some conditions 
from the popup menus.

Type the name for your Smart Album in the Smart Album name field. Then, using the 2	
popup menus, select the conditions to be met for items to be added to the album.

   

Our Smart Album, named Sea 
Anemones, uses the keyword 
“anemone” to populate itself.

Creating a Smart Album
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If you need more than one set of conditions, click the + icon on the right of the pane.  3	

   
To add more conditions,  
click the + (plus) button.

A new Smart Album appears in iPhoto’s left sidebar, and it contains photos that match the 4	
conditions you specified.

   

Our finished anemone album 
shows all photos with the 
keyword “anemone.” To add 
photos to that album, simply 
give them the keyword 
“anemone,” and those images 
will appear in the album.

Creating a Smart Album
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